Salesforce連携において下記のようなエラーが発生した場合に、TimeRexからエラーメールが送信されます。
Salesforce設定で更新トークン(リフレッシュトークン)が削除された
リード情報が重複した
必須項目が入力されなかった
なお、エラーメールは1週間に1回送信されます。
前回のエラーメール送信から1週間以内の場合、別のエラーが発生した場合もエラーメールは送信されません。
エラーメールを受信した場合、メール内のステータスコードを確認してください。
ステータスコードには下記のような種類があります。
"error":"invalid_grant"
DUPLICATES_DETECTED
REQUIRED_FIELD_MISSING
上記以外
各ステータスコードのエラー原因と対応方法は後述の通りです。
注意事項
TimeRexの仕様に関わらず、Salesforce側の「マッチング設定」の内容により、登録の可否が企業様によって異なる場合があります。
詳細は下記のサイトをご参照ください。
ステータスコード「"error":"invalid_grant"」の原因と対応方法
原因
Salesforce設定で更新トークン(リフレッシュトークン)が削除された。
または、Salesforce側でOAuthアクションの取り消しを行った。
対応方法
TimeRexのチームのオーナーまたは管理者にて、チーム設定>サービス連携>SalesforceよりSalesforceと再連携を行ってください。
また、再連携時にはSalesforceのアプリケーションマネージャ内にある「接続アプリケーション」の「OAuth ポリシー」セクションにて、「更新トークンポリシー」は「更新トークンは取り消されるまで有効」としておいてください。
ステータスコード「DUPLICATES_DETECTED」の原因
原因
リード情報が重複した。
同じゲストが複数回の日程調整を行うと、Salesforceにおいてリード情報が重複し、エラーが発生します。
ステータスコード「REQUIRED_FIELD_MISSING」の原因と対応方法
原因
必須項目が入力されなかった。
Salesforce側で必須としている項目が日程調整時に入力されていない場合にエラーが発生します。
例)Salesforceで会社名が必須項目であるのに、ゲストが日程調整時に入力しなかった
対応方法
該当の日程調整カレンダー作成/編集画面において、Salesforce側の必須項目を「ゲストから取得する情報」欄でも入力必須にしてください。
上記に当てはまらないステータスコードのエラーメールを受信した場合の対応方法
更新トークン・リード情報重複・必須項目の未入力以外のステータスコードが記載されたエラーメールを受信した場合、下記URL(Salesforce開発者ガイド)にアクセスし、エラーメールに記載されているステータスコードを検索してください。